升级Struts2之后报告HTTP Status 500 - java.lang.ClassNotFoundException: org.apache.jsp.index_jsp以及org.apache.jasper.JasperException: Unable to compile class for JSP

升级 Struts22.3.20.1版本升级到 2.5.5版本后可能报告如下错误:

也有可能发生如下错误信息:

具体信息如下图:

1422265899_66497

比较诡异的是,在 Tomcat 8的环境下,是可以正常运行的,但是在 Tomcat 7环境下却会报错。造成这个现象的原因就是在引入的 Jar包中包含了 jsp-api.jar这个 Jar包,只要在最后生成的 war包中排除这个文件即可。

发布者

发表评论

电子邮件地址不会被公开。 必填项已用*标注