ubuntu 17.10无法运行gparted,错误信息“Gtk-WARNING **: cannot open display: :0.0”

ubuntu 17.04无法运行gparted,错误信息“Gtk-WARNING **: cannot open display: :0.0”,具体信息如下:

具体的解释以及解决方法如下:

If running Ubuntu 17.10 or newer, this issue can arise when an application has not been updated with full support for Wayland. As a workaround until the application is updated, you can run

which will allow the root user to display applications on your desktop.

为了保证每次启动脚本都可以自动执行,可以把上面的命令加入到.bashrc:

参考链接


gksu: Gtk-WARNING **: cannot open display: :0

解决Windows Update提示“当前无法检查更新,因为未运行服务”

故障:点击“检查更新”,出现“Windows Update 当前无法检查更新,因为未运行服务。您可能需要重新启动计算机”,如下图:
继续阅读解决Windows Update提示“当前无法检查更新,因为未运行服务”