Struts2从2.3.20.1升级到2.5.5版本后报错:ClassNotFoundException: org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter

以前项目一直使用 Struts22.3.20.1版本,这个版本是 IntelliJ Idea新建项目的时候默认指定的版本,但是这个版本存在漏洞,必须进行升级,干脆一不做二不休,直接升级到最新的 2.5.5版本,但是运行的时候报告如下错误信息:

分析 Struts2-2.5.5的源代码发现

被更改了目录,变成了

只要如此修改即可。

发布者

默默

默默码农

发表评论

电子邮件地址不会被公开。 必填项已用*标注